questionshas anyone discovered a solution to the battery…

vote-for30vote-against
vote-for4vote-against

Dumb question: How do I ask my tablet (ASUS EPad) what version I have? Android isn't intuitive for me like Windows is. I have all kinds of trouble figuring out how to use it. It seems like since mine last updated the firmware it is eating the battery faster and Plants vs Zombies won't run on it anymore.

vote-for3vote-against

@moondrake: Settings>About Tablet. There should be an entry called Android Version. Mine updated to 4.0.3 (I think - from memory) maybe two weeks ago. I am also having a good bit of issues with particular apps (I assume because they haven't yet been updated for ICS). I don't know if I've tries Plants v. Zombies on ICS. I'll try it tonight.

vote-for11vote-against

Turn it off when you're not using it.

Otherwise here are the basic tips:

1) Don't use free apps that use adware. (This is where a major portion of battery usage happens.)
2) Reduce screen brightness.

vote-for2vote-against

Thanks, I'll check it this evening.

vote-for10vote-against

@xavoc: Does this mean that when you are out of range of wifi the adware won't eat the battery? Or does it still spend battery looking for a connection? Sorry for the dumb questions.

vote-for9vote-against

I have the galaxy nexus and haven't experienced any battery draining issues. I get approximately the same battery life I had with my Motorola Droid, even with the addition of 4g.

I don't use a lot of apps. Primarily Kindle, Facebook, Twitter, Gmail, Google Maps, One Bus Away, and the browser.

I can say as a dev the number one culprit of battery drain is unnecessary network usage. If you go into Settings -> Data Usage you should be able to see a breakdown of how much data each app you have is using. Some of the top ones should be obvious. Youtube, pandora, browser, these things are to be expected. If you have a game or some other 3rd party app that you don't think really needs the network but is taking up a sizable chunk consider getting rid of it.

vote-for8vote-against

@moondrake: If you are out of range of WIFI, turn it off in the Settings menu. It will save battery as well.

I have about 8-10 hours battery now without the last update. I keep ingnoring the install notification. I turn off apps I am not using, adjust screen brightness and have it on save mode, I also turn the auto-rotate feature off when I am not playing a graphics game. This all helps quite a bit, as before I only had about 3 hours worth of battery.

A fix, to my knowledge, has not been found. But with the above tips it should help you extend the battery life.

ADD: I don't watch video very much. I mostly read, surf the net, and edit docs, and skype with clients. Video will use a tremendous amount of battery.

vote-for5vote-against

On my Transformer I use Auto Airplane mode, an App (free) from the Market that saves my battery life by turning WiFi off when the screen goes dark.

vote-for2vote-against

I have a transformer and an experiencing the same issue. It's already set to disconnect wifi when in standby.

vote-for2vote-against

@moondrake: Well, when you're out of range of Wifi, your wifi radio is STILL on so, I'd just turn that off. Otherwise, it'll still try to connect, it'll just use less power as it's actually not downloading anything.

I tend to use ad-driven apps in airplane mode myself.

vote-for1vote-against

See, there's the problem! You are putting an ice cream sandwich on your phone! You are supposed to EAT the ice cream sandwich! Silly people!