questionshow can i fix it so i can hear the dialogue in…

vote-for19vote-against
vote-for14vote-against

Most discs also come with a two channel track for tv's without a surround setup. it sounds like you have a setting on the player or tv incorrect. If you are running an HDMI cable from the player to the tv, you more than likely need to check the tv sound settings. If you give me a little info, such as what player and tv you are using, and what connection between them, I can probably narrow it down.

vote-for5vote-against

@sadsephiroth: We're using a PS3 running an HDMI cable to a Aquos HDTV. I have set the audio to "stereo" before and I think it helped, but last night when were watching the "Thor" Blu-ray, there was no setting for stereo output . . . only 5.1.

EDIT: Whoops . . . forgot out HDMI output quit working after an electrical storm. The cable we're using is the Sony component multi-cable thing.

vote-for5vote-against

It would be helpful to know the make/model of your TV and Blu-ray player and to know how you've connected them (e.g. HDMI). Most Blu-ray players have audio settings as part of their menu systems that control what/where it outputs sound and in what format. It's possible your player is set to output in a format that your TV is not decoding properly. There are also sometimes settings on TVs that indicate what type of equipment is connected to what input. I would recommend going through the settings on the Blu-ray player first and see if you can find a setting that works well before changing settings on your TV. If you can't get it to work no matter what settings you adjust there may be alternate audio paths available (depending on how you have them connected now) such as an optical output on the Blu-ray and an optical input on the TV.

vote-for3vote-against

So what I'm worried about it: if the Blu-ray DOESN'T have stereo as an option, and my PS3 is automatically outputting 2 channels only, is it "blending" the center channel into the left and right channel, or is it just leaving the center channel out? If it's leaving it out, that may explain why we can't ever hear the dialogue over the other sounds.

vote-for5vote-against

@rayray8822: All discs will automatically do two channel if setup correctly. Running component from the PS3, are there 5 wires red green blue and red white, or are there 4 wires red green blue and something with a different tip? if it's the optical cable, which would cause what is happening, check the PS3 audio settings. Digital output needs set to 2 ch instead of 5.1. Then make sure your tv audio settings are not set to dolby digital or anything special/

here is PS3 settings
http://manuals.playstation.net/document/en/ps3/current/settings/audiooutput.html

On the tv setting vary by model, but should be easy to find.

vote-for3vote-against

@sadsephiroth: The cable is the "AV Multi-out Connector" component cable (5 connectors: red, green, blue plus red & white audio). It's not the cheap-ass composite one the PS3 came with. I bought this cable on Amazon after our HDMI output quit working (which is still a mystery).

I followed the link you provided and the Sony site says the AV Multi-out thing is only capable of 2 channel output (which makes since, I guess, since it's the red/white RCA cables). So from what you're saying, we shouldn't be having any problems . . . it should be automatically converting all discs to stereo.

vote-for5vote-against

p.s. This is yet another reason I love woot so much. Where else can I:
1) find deals without even having to get dressed
2) get $5 coupons just for doing #1
3) get answers for almost any question?

I've said it before, I'll keep saying It: You guys are great.

vote-for4vote-against

Yeah, it 'should' be, but I know the PS3 firmware updates did some screwy things to audio output. I would change it to a different setting and then back to 2 channel. All 5.1 tracks on bluray have an underlying 2.0 or 2.1 track, it seems like your PS3 is trying to output 5.1. Even with that cable you have to tell it to do normal 2 channel, because that port also supports multi channel.

Try these

http://playstation.custhelp.com/app/answers/detail/a_id/288/~/ps3-component-cable-sound-%2F-picture-troubleshooting

Edit: also make sure the multi output feature is disabled. New feature in firwmare 3 and higher.

vote-for4vote-against

If you are already using a downmixed stereo output (which you appear to be) you probably just need to adjust the dynamic range setting in your player. Look in the Audio setup menu of the player and find Dynamic range and set it to the minimum setting (sometimes called "midnight mode" or something similar).

vote-for3vote-against

Two settings to double-check:
First, in the Settings menu list, scroll down to Sound and go into the Audio Output Settings. Confirm that you're sending 2.0 audio (stereo) to your component cable output.
Second, go up to Video settings, then select BD/DVD Dynamic Range Control. Turn it to "on."

Your TV may also have a dynamic range control, which you should set to its narrowest value if you want consistent volume. You lose the dynamic experience, but it can be easier on the ears.