dealsbastion for iphone 3gs, iphone 4, iphone 4s…

vote-for1vote-against

You need to fix the title. It is not compatible with the 3GS and is compatible with iPad 2 and newer.

Straight from the link:

IMPORTANT Bastion requires an iPad 2 or newer, iPhone 4S or newer, or iPod touch (5th gen).

vote-for1vote-against

@riverzendz: whoops, that was the auto-generated title. Fixed